GoToConnect - Inbound call completion issues on Canadian numbers
Incident Report for GoToConnect
Resolved
We have confirmed that the issue has been resolved completely and all systems are 100% operational at this time.
Posted Apr 27, 2021 - 18:32 UTC
Monitoring
Our Canadian provider has corrected the issue and we are confirming that all services are functional.

We will continue to monitor the situation and will provide a final update shortly.
Posted Apr 27, 2021 - 18:04 UTC
Identified
Our engineers have identified that the issue is caused by one of our Canadian providers and they are actively working towards a resolution. We will provide more updates as soon as they become available
Posted Apr 27, 2021 - 17:05 UTC
Investigating
We are currently investigating issues of inbound call completion to a subset of Canadian numbers on GoToConnect.

The service provider is actively investigating on the root cause of this issue and we will provide more updates as they become available.
Posted Apr 27, 2021 - 15:48 UTC
This incident affected: PSTN Calls (Inbound).