GoToConnect - Call Quality
Incident Report for GoToConnect
Resolved
Our engineers have completed testing our Applications, all alerts have cleared, and this issue is closed. Please feel free to reach out to our Customer Care team should you have questions or comments.
Posted Feb 16, 2021 - 19:58 UTC
Monitoring
The Network Operation Center has completed our necessary remediation efforts and we believe that service has been restored. We will send another update soon as we completely test our Applications and alerts have cleared.
Posted Feb 16, 2021 - 19:14 UTC
Investigating
We are actively monitoring reports that some GoToConnect customers may be experiencing call quality issues, due to network issues outside of our direct control.

We are taking corrective actions to minimize impacts on GoToConnect customers.
Posted Feb 16, 2021 - 19:11 UTC
This incident affected: PSTN Calls (Inbound).